close
{{currentManName}}swap_horiz KRKswap_horiz Find a manufacturerkeyboard_arrow_down

KRK Rockit 5 (RPG2) Intermittent fault

Hi there,

I bought a pair of KRK System's Rockit 5 (RPG2) Desktop Speakers in May 2013 from Belfield Music on eBay, brand new and they have worked perfectly since then, except recently (last couple of weeks) I've noticed the left speaker having an intermittent fault, where sound cuts in and out, and a static sound coming from it, turning the volume nob on the back brings the sound back but then disappears again. I have checked all cables and made sure everything is in firmly, but still this problem persists, right speaker works perfectly.

Does anyone have any suggestions?, I don't think I can get warranty on it as it's been more than 1 year (outside of USA) and eBay/PayPal's purchase history doesn't go back that far, and I deleted the receipt emails once I received the product, I do however have the original boxes that they came in, so there might be some proof of purchase on the labels.

What are your thoughts?,
Thank you,
-EIN
It does sound like a problem in the monitor itself, but just to be sure, try switching the left and right monitors to confirm that the problem switches sides, too. You want to eliminate the possibility that the trouble is coming from your interface or whatever other audio source your monitors are connected to.

Once you're sure it's the monitor, I guess your next step is to contact Gibson, who owns KRK and provides its customer service and see if it's a problem they've encountered before or if they have any other advice for you. Their phone is 1-800-444-2766, email is: http://www2.gibson.c…on/Talk-2-Us.aspx. I doubt that you'll be able to get warranty service based on what you've said regarding receipts and ownership, but it doesn't hurt to ask. If not, they can probably recommend a qualified repair shop in your area. Good luck!
Quote from EverythingIsNothing:
What are your thoughts?,
Thank you,
-EIN


I've had issues with my KRK rokit 8s where a popping sound would sporadically occur on top of playback. I found out my issue was the drivers on the main board, which thankfully I was able to fix myself by ordering a new board for 90 bucks and simply unscrewing and replacing a couple things (I am by no means a DYI guru). With that said, I'm not sure your issue is with the drivers, as it's a slightly different intermittent fault.

I would try KRK's troubleshooting steps for 'no sound' if you haven't already: http://www.krksys.co…ble-shooting.html

good luck
yep no worries, thanks for the replies.

I contacted them and I fall out side of the warranty stage so they suggested a place locally to me to get it repaired.

Cheers.
Yet another reason to go for Equator D5s next time
1/1

Most active threads

Latest questions