close
{{currentManName}}swap_horiz Focusriteswap_horiz Find a manufacturerkeyboard_arrow_down

Focusrite Scarlet 18i8 with MacBook Pro M1 issues

So, I went and purchased the 18i8 since both in advertisements and also in a chat with support they guaranteed that it works. Unfortunately my previous Saffire Pro 26 is not supported. Anyways, I knew that Focusrite control doesn't work. Anyways, to make a long story short, I connected it and first time it showed up under sound setting of the Mac. I played something and sound came out from the monitors but the volume was all the way up despite the knob being at min. I then connected my headset and same thing, no volume control. I decided to reset the computer and the sound card and after the reboot the M1 didn't recognize the 18i8 any more. Just doesn't appear.

I tried my old late 2013 intel MacBook Pro and after connecting it I didn't see the 18i8 in the sound settings either. Only on the intel I could load the Focusrite control app and bam the interface appeared.

So, if I need the Focusrite control app to even make it regonize the interface, why is Focusrite advertising it as if the 18i8 is compatible with the m1 (but the Focusrite control isn't supported yet). It is useless until they make the Focusrite control compatible.

SOoooooo frustrating.

Would love to hear if anyone else experienced this and if you guys found a solution.

Frustrated Focusrite client.
Same here! I contacted Focusrite about the following issue:

I had a Saffire Pro 40, but had to move to a Scarlett 18i20 (3rd Gen) due to incompatibility with my new M1 Macbook Pro. Absolutely no issues in the first 2 weeks, however, this morning, I wake up and there are no inputs/outputs available other than the main mic and speakers. I see under “System Report” that the system recognizes the connection under “USB” and Imve gone as far as deleting and reseting the OS Core Audio, but to no avail, no difference. My other option was to just factory reset the interface, since it worked in the beginning, but that can only be done in the software, which is not compatible with the new Macs yet. Such a shame if there is no solution but to wait till the Focusrite team can finally fix this issue. I’ll keep this posted if I hear a response, good luck to any others and help if you have a solution eek !
1/1

Most active threads

Latest questions